Home Forums WC Vendors Pro Support 404 Error with Permalinks

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.Β  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #13891
    mika28
    Participant

    Hello,

    This particular Permalinks scenario builds a desirable URL structure for me:

    permalinks input:

    Product category base: custom
    Custom Base: /custom/%product_cat%

    result:

    .com/custom/category/
    .com/custom/category/product/

    However, it also creates the 404 error when viewing categories. Products work fine. Changing “Product category base” to something_else fixes the 404 error but creates undesirable URL structure. Not sure if it’s a bug, a shortcoming of WP, or me :). Will appreciate any help.

    Thank you

    #13892
    WC Vendors Support
    Participant

    wp-admin > Pages > All Pages > Edit the page titled “Shop” and change the slug/permalink of that page to /custom/

    Then all that stuff should work just fine. πŸ™‚ That’s what “Shop Base” means. The slug of the SHOP page. πŸ™‚ By changing it to /custom/ you’re ignoring the shop layouts and nothing works.

    It’s not a bug, not a shortcoming of WordPress, or a WooCommerce or a WC Vendors problem, it’s a you-configured-it-wrong problem. πŸ™‚ πŸ™‚ πŸ™‚

    Cheers

    #13907
    mika28
    Participant

    Thanks for a quick reply.

    I changed the slug of the base shop page from /shop/ to /custom/ , but it still the same story as before.
    Again, removing the word β€œcustom” and leaving the default product-category or putting something else there fixes the 404.

    On a side note, in case it’s related, when clicking Sold by: Vendor link it lists all the products in the store (instead of listing only the products by that vendor ). Thanks

    #14154
    mika28
    Participant

    I’d like to follow up on my last message. Thanks

    #14161
    WC Vendors Support
    Participant

    I’m sorry, I thought you resolved your problem:

    “Again, removing the word β€œcustom” and leaving the default product-category or putting something else there fixes the 404.”

    I’m not entirely sure what you’re asking if the problem is fixed?

    #14171
    mika28
    Participant

    The “fix” creates a different (undesirable) URL structure

    .com/something_else/category/
    .com/custom/category/product/

    So my initial question was about how to achieve these URLs:
    .com/custom/category/
    .com/custom/category/product/

    Thanks

    #14173
    WC Vendors Support
    Participant

    That’s just how WooCommerce works. This is not WC Vendors related (at all). WooCommerce has a slug for categories, and a slug for products. I”m afraid we cant help on this one because it’s a WooCommerce issue that is not possible to actually fix.

    #14180
    mika28
    Participant

    Ok. And how about the second issue (let me know if it needs another thread)?

    Sold by: Vendor link lists all the products in the store (instead of listing only the products by that vendor in the link )

    #14181
    WC Vendors Support
    Participant

    That’s also a WooCommerce setting. πŸ™‚

    wp-admin > WooCommerce > Settings > Products > Display > Shop Page > [X] Products

    If that doesnt fix it, please set a private reply with the URL that is giving you trouble and we’ll check it out and see what it is.

    #16188
    WC Vendors Support
    Participant

    Let’s have @digitalchild look at that for you

    #16398
    mika28
    Participant

    Thank you, here is the website: oriniq.com. (Although I guess it should be visible via the activated plugin license)

    #16442
    mika28
    Participant

    Ben,

    Thank you for fixing this and the extra tune up!

    Best,
    Mik

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.