Connect to Stripe Button Not Working

This topic contains 18 replies, has 6 voices, and was last updated by Profile photo of Anna Anna 3 months, 2 weeks ago.

  • Author
    Posts
  • #32951 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    As per other post, I cannot connect vendors to Stripe. This is a new install of Stripe. I have tested all the settings and they are working fine and the site is now live.

    When clicked, the page authorises Stripe then goes back to My Account. When you go back to the Dashboard it still says not connected.

    When I checked in the Vendor’s Stripe dashboard it said that it was connected to the site with read/write access.

    I tested with a live transaction and the payment went through, but not to the vendor account.

    #32952 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit
    This reply has been marked as private.
    #32972 Score: 0
    Profile photo of ben ben 
    WC Vendors Official Support
    289 pts
    @ben

    Logging in to begin tests now…….. standby……….

    #32975 Score: 0
    Profile photo of ben ben 
    WC Vendors Official Support
    289 pts
    @ben

    User Switching in Admin Bar…. Nifty. Didnt know that existed. I shall now add that as well as User Switching when I work on sites. ๐Ÿ™‚ Thanks for that.

    I tested, and tried to add my personal Stripe Account to your vendor account, and it did indeed fail. Here’s some things to test out, before we go to the next round of testing. If all these fail, let me know:

    1.) Verify that you are in LIVE/PRODUCTION mode with Stripe, not test mode in your gateway settings and that your keys are accurate. (They are on your site, so you can ignore this, but I type that for future members viewing this thread with a similar issue). Also make sure on STRIPE.COM that you are in Live mode. There’s a slider at the top left that can toggle test or live. I’m not honestly sure if that actually matters or not, but do it anyway. ๐Ÿ™‚

    As the vendor, add this URI to your current URL — ?disconnect_stripe_connect=true so if you are example.com, go to example.com/?disconnect_stripe_connect=true and that will manually force disconnect Stripe if it is in limbo.

    2.) Disable all plugins other than WC Vendors Free, Pro, WooCommerce, and Stripe. No other plugins no matter what for any reason no matter how trivial you think they may be, they ALL matter. ๐Ÿ™‚ Also, switch to the Storefront theme. Then test as the vendor.

    If #2 did not work, please check your phpmyadmin for the user ID of the vendor for this meta key: _stripe_connect_access_key — it will be in the user meta table. If it exists, let me know.

    3.) From there, if things arent working, we’ve got some issues and it’s most likely Stripe not wanting to “talk” to your webserver. SSH to your webserver, and type: curl https://api.stripe.com/ (enter). You should receive this response:

    {
      "error": {
        "type": "invalid_request_error",
        "message": "You did not provide an API key. You need to provide your API key in the Authorization header, using Bearer auth (e.g. 'Authorization: Bearer YOUR_SECRET_KEY'). See https://stripe.com/docs/api#authentication for details, or we can help at https://support.stripe.com/."
      }
    }

    If you get that response, that means your webserver CAN communicate with Stripe without any problem.

    Let me know how it goes! I may ask you for a Skype ID so we can video chat and sort this out in real time if none of these steps solve the issue.

    #32997 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    Thanks Ben. I’l run through them when I get a chance.

    #33032 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    OK all done and sorry to say no fix!

    1. Done and rechecked. No change
    2. All plugins off and switch to storefront. No change. META key for vendor is there.
    3. Response as you stated so can communicate.

    The only things I can think of is that I had a lot of bother getting the SSL cert working on the site and my server team eventually stepped in and helped me out. They did a search and replace and the whole site is now running on HTTPS.

    I also had to add the following to wp-config.php for the site to work:

    define('FORCE_SSL_ADMIN', true);
    define('FORCE_SSL_LOGIN', true);
    if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https')
    $_SERVER['HTTPS']='on';

    If I remove these lines I get stuck in a redirect loop when trying to access the site. SSL stuff is beyond me and new to it all. Something to do with reverse proxy / load balancers? https://codex.wordpress.org/Function_Reference/is_ssl

    #33264 Score: 0
    Profile photo of ben ben 
    WC Vendors Official Support
    289 pts
    @ben

    They did a search and replace and the whole site is now running on HTTPS.

    Eek. That sounds like they did a search and replace on your websites database. If they don’t know what they are doing, that can get ugly — very ugly — very very fast.

    Did it work BEFORE they did this?

    #33331 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    No, I couldn’t even get as far as the checkout before due to redirect errors so they suggested changing the site over to https entirely. Everything has since worked fine apart from this…

    #33402 Score: 0
    Profile photo of ben ben 
    WC Vendors Official Support
    289 pts
    @ben

    Ok, that’s good. That means there’s something goofy going on or something interfering. Ready for the next test? Disable all plugins other than WC Vendors Pro, WC Vendors, Stripe, and WooCommerce. Try adding it then. If a plugin is conflicting, that’ll tell us right away.

    @sonic1832 and @jamiekeefer These are two other members reporting similar issues out of the blue, so there’s gotta be something screwing or conflicting with Stripe. Hopefully Sonic and Jamie can review this thread to help get the problem solved even faster.

    If that doesnt work, we’re going to get on Skype together and look at your Stripe.com account to see what’s going on.

    ——

    Sonic, and Jamie: For the user you are connecting to Stripe, get their user ID #. Look in phpmyadmin in wp_usermeta for that user ID # and see if you see a meta key of “_stripe_connect_access_key”. If you do, is its value empty, or does it contain a string of letters/numbers? Al: Yours is empty which means Stripe isnt giving you the connect access key ID. Al, please check this again after you did the next test of disabling plugins. Jamie & Sonic, please do the disable plugins test.

    Let me know how it goes. We’ll get it done, just gotta figure out wtf is going on first. It’s a but awkward to test because it requires full social security numbers and bank account numbers to actually connect to stripe, I cant keep using mine to open more accounts and my fake ID supplier doesnt call me back anymore! ๐Ÿ˜‰

    #33407 Score: 0
    Profile photo of jamiekeefer jamiekeefer 
    4 pts
    @jamiekeefer

    I just installed the woothemes stripe gateway and everything works fine.

    Im in business.

    Jamie

    #33415 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    Yeah I’d tried disabling all the other plugins Ben but no luck. That was number 2 on your original list to try – unless you mean something different? Is it worth deleting that key from the database then trying again?

    As you say the key is there, but blank.

    Al

    #33441 Score: 0
    Profile photo of jamiekeefer jamiekeefer 
    4 pts
    @jamiekeefer

    To clairfy, I have had other problems besides the that button not working, hasn’t worked for a while. I just opted to pay people via paypal. I was getting rejected transactions with the WCVendors Stripe plugin which seem to be resolved with the woothemes stripe plugin. See other thread.

    Thanks

    #33448 Score: 0
    Profile photo of Mathias Mathias 
    1 pt
    @sonic1832

    Hi Ben,

    sorry that it has taken me some time. I have 2 sites, sandbox and production and performed a couple of tests on both.

    1. I disconnected an existing user from stripe – works
    2. Connect him again – doesn’t work (now I even don’t get the success notification anymore:-)

    Regarding your To Do’s
    1. I checked the php_my admin and there is only one “_stripe_connect_access_key” accosted to user ID 8 (one of my vendors). The other test user 9 (vendor 2) doesn’t have such a key
    2. I turned of all plugins (incl. buddy press which I thought might be the root cause since i updated this one yesterday) and activated just stripe connect – using the connect button again – no luck. Also the table doesn’t change

    3. I checked my stripe settings and figured a misconfiguration in the Connect Tab in the stripe dashboard:
    I recently changed to SSL “https://” and there was still the “http://” link to “../my-account”. I changed that and IT WORKS again:-)

    regards
    mathias

    #33449 Score: 0
    Profile photo of Mathias Mathias 
    1 pt
    @sonic1832
    This reply has been marked as private.
    #33453 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    Glad you’ve fixed it. Got me excited but my settings all seem to be correct.

    • This reply was modified 9 months, 4 weeks ago by Profile photo of alwhit alwhit.
    #33455 Score: 0
    Profile photo of alwhit alwhit 
    2 pts
    @alwhit

    FIXED! In my Stripe settings I had URLs as https://mysite.com… It needed to be https://www.mysite.com for both the site and redirect URLs. I had assumed this was fine as the redirects were working, but it just wasn’t connecting.

    Can I suggest adding some code to the plugin if possible to indicate a failure to connect to Stripe after redirect? I wasn’t getting any sort of message to say it had failed before, whereas you do get a message if it succeeds.

    Thanks for all your help.

    #33456 Score: 0
    Profile photo of Mathias Mathias 
    1 pt
    @sonic1832

    Hi Ben,
    Also it would be create if I could redirect the vendor to his dashboard settings – payment without losing the functionality. Is that possible?

    Cheers
    Mathias

    #49189 Score: 0
    Profile photo of Megan Megan 
    @megtheodoro

    I am having this same problem and can’t get mine to work

    #49275 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    178 pts
    @fervous

    @megtheodoro
    Please keep all future replies in regards to your Stripe question here: https://www.wcvendors.com/help/topic/commission-not-transferring-to-vendor/
    There is no need to keep pinging the OP with new replies, as your issue is likely unique. There is also no need to open multiple threads/replies in regards to your issue.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.

ยฉ2009-2017 WC Vendors ยท Terms of Service, Support, and Refund Policies

Log in with your credentials

or    

Forgot your details?

Create Account