Home Forums WC Vendors Free Support Edit Instant Payment Notification (IPN) settings

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #9145
    Global
    Participant

    Hi support,

    I set up a new Paypal Adaptive Payments as my old one was not working correctly – it was not scheduling payments.

    I did a live test sale and noticed that I did not receive a sale notification email from my site. I contacted Paypal and they informed me that my IPN had been disabled. They sent me the below instructions on how to reset it.

    “PayPal sends IPN messages to the URL that you specify below.

    To start receiving IPN messages, enter the notification URL and select Receive IPN messages below.”

    I found the below url on woocommerce support site which they advise to use but I read in a thread that the below would not work if woocommerce had been modified. Not sure if WCV/woocommerce is classified as modified?

    http://example.com/?wc-api=WC_Gateway_Paypal

    Please can you advise what IPN notification URL I need to add?

    Your help is very much appreciated.

    Thank you 🙂

    Regards,

    Paul

    • This topic was modified 7 years, 4 months ago by Global.
    #9151
    WC Vendors Support
    Participant
    #9164
    Global
    Participant

    That’s great Ben … thank you so much 🙂

    You guys must be crazy busy with your pro launch … wishing you every success with it! … im sure its going to be awesome!!! 🙂

    #9183
    Global
    Participant

    Hi support,

    Not sure if I am supposed to put my sites domain name where example.com is below:

    http://example.com/?wc-api=WC_Gateway_Paypalap

    Tried the url http://globalfashion.space/?wc-api=WC_Gateway_Paypalap, however is not working … I did another test sale but didn’t receive an email informing me of a sale. I checked on Paypal Instant Payment Notification (IPN) history and it is saying retrying. http://globalfashion.space/?wc-api=WC_Gateway_Paypalap

    Any advice would be great.

    Thank you.

    Paul

    #9187
    WC Vendors Support
    Participant

    Hi Paul,

    You shouldnt even need to put anything for this, the gateway tells PayPal where to go each time. You are using PayPal Adaptive Payments? Or something else?

    #9193
    Global
    Participant

    Hi Ben Yes … thats what happened the first time I setup adaptive payments … I didnt need to do anything. But when I set up a new adaptive payments yesterday and tried a test sale … I didn’t get a sale notification. I call Paypal and they said IPN was showing disabled. They directed me to to a page on Paypal to reset it. I noticed there was an old Ecwid url there (I havnt used ecwid for 4 years) instead of http://example.com/?wc-api=WC_Gateway_Paypalap I think that’s why my IPN was disabled.

    I deleted the ecwid url and tried to reset with no url and I got the following warning: You must enter a properly formatted URL into the Notification URL field in order to activate Instant Payment Notification.

    I just spoke to Paypal and asked them if they knew the url and they said they didn’t know what it was and I should speak to the platform owner. I am always the only one that has such bad luck with Paypal OMG … so not fair ha 🙂

    #9194
    WC Vendors Support
    Participant

    When PayPal finally works, it works fine. But damn, getting them to support you and figure out what to do is always a nightmare. Their customer service is one of their weakest aspects of PayPal.

    Quite frankly, I would tell them to delete your existing Adaptive Payments account and then re-apply with the new site information that way it’s a clean install. Sounds like they’ve got an issue with THEIR settings somewhere for your account, rather than a WooCommerce/You problem.

    #9200
    Global
    Participant

    Yes its just getting Paypal to work for me is my problem … Things keep happening to me that never happens to anyone on the forum with Paypal … I will get it to work! 🙂 🙂

    I will get them to delete … Hope you have a nice evening Ben

    Thank you 🙂

    #9254
    Jamie
    Keymaster

    Hi Global,

    Also make sure that this all works with sandbox credentials. That way you can give paypal that information and say ‘this is my domain and my sandbox credentials that are working just fine’ Make my damn account work!

    cheers,

    Jamie.

    #9259
    Global
    Participant

    Thank you Jamie,

    Paypal fixed the IPN problem today wow … thats amazing 🙂

    I have never been able to get the scheduled payments to work as paypal wouldn’t allow it for me. ( I know I must be the only one from all your users of wcv 🙂 so unlucky … at the time they said for me to cancel and set up my adaptive payment setup again. I did this a couple of days ago.

    Today I did a live test sale for £1, I the marketplace owner received £1 / 100% of the sale from paypal. I received an email from my site informing me of the sale and showing £1 / 100% of the sale. The vendor received an email from my site informing them that they had a sale showing .90 pence / 90% of the sale. In my back office I set up that I would receive 10% and checked schedule for the 90% of the sale to go to the vendors paypal account in 7 days time.

    Will paypal automatically pay the vendor their 90% of the sale via Paypal in 7 days time?

    Thank you for your advice,

    Regards,

    Paul

    #9260
    WC Vendors Support
    Participant

    That’s right! As long as you have it scheduled BEFORE THE SALE OCCURS in your WC Vendors > Payments tab to pay weekly, it’ll pay all sales every 7 days from the time you click save. Glad you got it all sorted out. 🙂

    #9261
    Jordan
    Participant

    I’m currently using {domain}.com/?wc-api=WC_Gateway_Paypal and it seems to be working fine. Is the IPN url supposed to {domain}.com/?wc-api=WC_Gateway_Paypalap?

    #9262
    WC Vendors Support
    Participant

    You shouldnt have to have that setup at all.

    https://github.com/wcvendors/wcvendors/search?utf8=%E2%9C%93&q=WC_Gateway_Paypal <-- Nothing found for WC_Gateway_PayPal If it works, leave it, but you dont need to have anything set for IPN.

    #9263
    Global
    Participant

    Thats great Ben … thank you for all your help with my Paypal … I will be counting down the 7 days … and celebrating if Paypal actually works for me 🙂 🙂 Hope you guys have an Amazing weekend 🙂

    #9264
    WC Vendors Support
    Participant

    You’re very welcome as always! Cheers 🙂

    #9266
    Jordan
    Participant

    Oh ok, so the IPN url is set by the gateway and is separate from WooCommerce’s IPN settings. Thanks!

    #9268
    WC Vendors Support
    Participant

    Yup, that’s correct. PayPal Adaptive Payments knows where to send the IPN because you sent a visitor to them with all that info in it automatically with the gateway. Most gateways still support IPN urls but it’s more of a legacy option since most all are automatic now.

Viewing 17 posts - 1 through 17 (of 17 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.