Home Forums WC Vendors Pro Support Error while uploading Image

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #65204

    The problems happened after I updated WordPress, woocommerce and wcvendors pro so Im not quite sure where the issue is.

    As stated, Im having troubling with my site where vendors unable to upload product images (both featured and gallery). I have tried changing to the basic themes and deactivating plugins to no avail. I have tried with Firefox and Chrome with similar problems.

    Uploading both on post and product seems to be working on admin frontend. The problems happen when vendors try to upload image or accessing their media library. There is no php error
    but only browser console error:

    (media-views.min.js?ver=4.7.4:2)
    Uncaught TypeError: this.$el.sortable is not a function
    at n.initSortable (media-views.min.js?ver=4.7.4:2)
    at n.initialize (media-views.min.js?ver=4.7.4:2)
    at n.e.View (backbone.min.js?ver=1.2.3:1)
    at n.constructor (wp-backbone.min.js?ver=4.7.4:1)
    at n.constructor (media-views.min.js?ver=4.7.4:4)
    at new n (backbone.min.js?ver=1.2.3:1)
    at n.createAttachments (media-views.min.js?ver=4.7.4:2)
    at n.initialize (media-views.min.js?ver=4.7.4:2)
    at n.e.View (backbone.min.js?ver=1.2.3:1)
    at n.constructor (wp-backbone.min.js?ver=4.7.4:1)

    Im lost.

    #65228
    Anna
    Member

    @icronos
    First, try deactivating all plugins except WooCommerce, WC Vendors and WC Vendors Pro. Login as a vendor using the my-account page. See if this resolved the issue.

    If not, try installing the Really Simple SSL plugin. https://wordpress.org/plugins/really-simple-ssl/ run through the options to secure content on your site.
    Then try again to see if the issue is resolved.
    Let me know.

    Plugins such as wpsmush and other image plugins can sometimes disrupt the image uploaders.. as well as permissions and having insecure content on your site.

    #65238

    Anna, Thank you for the prompt reply. I got it to work again, I forgot to clear the cache before deactivating rest of the plugins on my first try.

    #65258
    Anna
    Member

    @icronos
    Glad to hear this is resolved! Let me know if you need anything else.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.