Flat Rate is not working properly

Home Forums WC Vendors Pro Support Flat Rate is not working properly

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

Thank you to all of our customers!

 

This topic contains 7 replies, has 3 voices, and was last updated by  Anna 1 year, 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #52470

    Esme
    Participant

    Hi friends,

    I’m setting Flat Rate for vendors but I have a problem with national / international rates. Using a test account, I create a vendor account shipping from Spain and set 5 euros for national shipping and 10 for international shipping. When I try to purchase a product from Spain, checkout just calculate 10 euros as vendor shipping, neither showing nor re-calculating to 5 euros. Maybe I have to set any additional item?

    You could test it at http://esmem.sg-host.com/. All products you could see are shipped from Spain. At product page you could see both shipping rates, and at checkout you could see the national rate is not applied.

    Thank you in advance for your help 🙂

    #52499

    Anna
    Keymaster

    @emcardenal
    Please double-check that your test vendor account has entered the Store Address and the Store Shipping address in the store settings & shipping settings:
    pro dashboard > settings > store
    and
    pro dashboard > settings > shipping

    Also, please reply with your WooCommerce System Status.

    #52564

    Esme
    Participant

    Hi again Anna,

    Thank you for your help. I’ve found the problem: at shipping tab in Pro Dashboard the default option is “address store”, but I don’t include the address store information. If I choose “shipping > other” and choose Spain, it works, so I suppose I need to activate store address or make this option (shipping > other > country) mandatory when vendor setup his account.

    Anyway, when I visit “wc vendors > setting form”, I see the following message: “Store address ( if you use pro shipping this option will not work. )”, and certainly this information isn’t appearing in Pro Dashboard settings, so why is “store address” an option in the shipping tab? Is there any other place to setup it?

    Thank you and best regards,
    Esme

    #52621

    Michele
    Participant

    Hi, I have disabled international shipping from the dashboard and in doing so, all products have NO shipping options.
    I then created a 2.99 flat international shipping fee and that is the default shipping on all products — the 1.99 flat fee (default for national shipping is not). I enabled geo-location — still doesn’t work. I checked the box to “hide shipping until address is entered” but the flat international fee keeps showing.
    The per vendor/per product is NOT overriding the default international fee.

    ### WordPress Environment ###

    Home URL: http://www.isaacsestand.com
    Site URL: http://www.isaacsestand.com
    WC Version: 2.6.11
    Log Directory Writable: ✔
    WP Version: 4.7
    WP Multisite: –
    WP Memory Limit: ❌ 40 MB – We recommend setting memory to at least 64MB. See: Increasing memory allocated to PHP
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US

    #52623

    Michele
    Participant

    BTW, I tried to upload pdf of the screen shots but the file type is not accepted — how can I send the screen shots of some of the tabs?

    #52663

    Anna
    Keymaster

    Hello,
    First check and make sure your vendor(s) has entered a store shipping address, and that this has been set in their store settings > shipping as the shipping from address.

    Secondly, we do have a bug with International product level override in shipping; this is being or has been fixed and will be available in the next Pro release.

    Is the vendor’s own default shipping rate working properly? Is it just the product level shipping rate/override that you are having difficulty with?

    #52701

    Michele
    Participant

    Yes, the product shipping rate was the issue. 

    If a vendor DOES enter a shipping rates in the store settings tab, does it show up under their banner on the “view store” tab? 

    I have seen this a few times and I DO NOT want addresses made public of the sellers. 

    #52758

    Anna
    Keymaster

    Hello,
    To ensure that you do not publish your vendors’ locations, you can do the following edit to your store-header.php file:
    1. First, make a folder in your theme/child theme file called: wc-vendors
    2. Make a folder within wc-vendors called: store
    3. Go to your plugins > wcvendors-pro and find the store-header.php template. Here’s the path: wp-content/plugins/wcvendors-pro/templates/store/store-header.php
    4. Copy that template and move it to the folder in your theme/child theme you just created: wp-content/themes/your-theme-or-child-theme/wc-vendors/store/storeheader.php
    5. Make these two edits:
    Remove approx line 55, which looks like this:
    $address = ( $address1 != '') ? $address1 .', ' . $city .', '. $state .', '. $store_postcode : '';

    Save .

Viewing 8 posts - 1 through 8 (of 8 total)

The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.