Home Forums WC Vendors Pro Support Image upload failed

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.


Thank you to all of our customers!


Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #56080


    I just purchased WC Vendors Pro after experimenting with the free version for a while.
    Previously I managed file and image uploads via Advanced Custom Fields and User Frontend Pro without any issues.
    I always experienced issues with the WordPress file upload. Especially when using it via the frontend. I did everything to avoid it on my site and now after upgrading to WC Vendors Pro I have the issue that I had 2 years ago again.
    I do not want to expose users to the whacky WP file upload and media browser but just open the Desktop or Mobile file browser and nothing else.

    Is there a way to simplify the file upload like this on WC Vendors. This is very critical for the workflow on my site. The WordPress Media upload does not work and throws http errors.
    You even use a file upload like this here at your support submit form btw. 😉

    Would appreciate any help.
    I can also demo it on my website.

    Thank you very much


    Oh I wish I could be more help- I do not use ACF so I do not know how this would be done with the file and image uploads for WC Vendors Pro. I will see if I can get any help for you…
    The HTTP error may be due to some insecure content on your site- I assume you are running SSL? If so, then you may want to try installing the plugin Really Simple SSL to see if this takes are of the warning. https://wordpress.org/plugins/really-simple-ssl/


    Hi Anna,

    no I am using no SSL on my site so far.
    Concerning the image upload I need something similar and simple to what you use here in your support forum.
    press browse button -> select file -> file upload -> finish

    Additionally to the upload issue I get the following error on some other page, where I start a frontend-editor for a form.
    Fatal error: Class ‘WC_Order’ not found in …/wp-content/plugins/wc-vendors-pro/public/class-wcvendors-pro-vendor-controller.php on line 262

    If I deactivate WC Vendors Pro everything is fine again.


    Have you tried leaving Pro activated, along with WooCommerce and WC Vendor (free), and tested?
    When I have seen this error before, it was caused by one of three things:
    1. the user did not have WC Vendors free and WC Vendors Pro BOTH activated
    2. Another plugin
    3. the user had deleted a bunch of orders instead of reversing them, then deleting them. Or instead of removing them from the db.

    So, you can check those three things- I am pretty sure it is not #1.

    Could you also please share your WooCommerce system status in a reply? wp admin > woocommerce > system status

    Regarding the image uploading forms- we have built in the image uploader in our front end forms to work with the woocommerce product listing format, and the wordpress uploader and media library. That is how our forms are built. If you need to custom build in forms, that will be a task that you or a hired developer will need to undertake.
    If you are using any plugins that mess around with your media then this may be causing the http issue- since you are not using SSL on your site (are you using it on the checkout pages?).

    Please try deactivating the plugins as I instructed above – and test – and then also please provide your WooCommerce System Status in a reply.
    Thank you.



    I made some progress in debugging and searching for the problem.
    The conflict is caused by the WP Toolset Access plugin.
    If I deactivate it, I can upload images to WC Vendors without problems (through the wacky WP media uploader).
    The issue is that I need Access to set rights for my custom Types. Else the user will not be able to edit his/her postings. So I am in a dilemma now. If I deactivate WC Vendors Pro I could have stayed with the Free version. If I deactivate Access my the purpose of the site to edit user posts is gone. If I activate both I get the error in post #56194 from WC Vendors.

    Anything we can doe there?


    Forgot to say that if I deactivate Access I get this error on my front-end editor:

    Sorry, you are not allowed to access this page.


    Are these custom roles that you need to provide access to?
    If so, you do not need the plugin… there are other ways to do that.
    Please clarify.
    Apparently that is one of the few plugins that does not work well with WC Vendors.
    I imagine it has to do with the roles or access how those are set..
    I am unclear on how you have this all set up on your site..



    I just disabled the Access plugin and set the rights using the User Role Editor plugin.
    Now I have the following issue. The Frontend Editor redirects to the WC Vendor Dashboard instead of showing up the fields to edit. So I assume that there is a conflict in a function call or whatever.

    Again if I disable WC Vendors it works flawless.


    Jan, I am sorry- but I do not understand your configuration… Which front end editor are you referring to? Our Pro front end forms? Or are you using some other front end editor?
    I do not see anything wrong in the dashboard in the screenshot.


    Sorry. I use ACF Live Edit .
    The issue is that if I start to edit a form with this plugin, the form does not open as intended but I am redirected to the WC Vendors Dashboard instead.
    Because there is no feature in the Live Edit Plugin that redirects to the dashboard page, this makes no sense to me.
    The only explanation I have is, that there might be a conflict between WC Vendors and this plugin.
    Unfortunately I cannot replace or remove this plugin in favor of WC Vendors.

    Do you have any clues?



    Hi Ben,

    thank you very much. This solved indeed the issue.
    Any advice on replacing the uploader with a simple one where the user can browse locally to choose a file for upload?


Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.