Home Forums WC Vendors Pro Support License Activation System Has Been Disabled

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #65175
    Nicholas
    Participant

    Hi,

    I recently moved web hosts, and how I am getting the message that the license activation system has been disabled (per attached image).

    WC Vendors Pro has detected you are running on your http://www.wcvendors.com. The license activation system has been disabled.

    I can’t find where to reactivate the license. Also, I realize I will need to upgrade MySQL to at least v5.6 (working on that now), but reckon this error may be beyond that since the message insists I’m from http://www.wcvendors.com when in fact I’m not.

    Any help would be appreciated.

    Thanks!

    #65177
    Nicholas
    Participant

    Just an update that the database had been updated to 5.6. (Same issue remains, though.) Thanks.

    Also, I didn’t realize the first post was public, so I deleted the screenshot of our admin dashboard (and moved it here). I was hoping the first post was private for support only.

    • This reply was modified 5 years, 8 months ago by Nicholas.
    #65221
    Anna
    Member

    @nicholas
    Could you send an admin password & login in a private reply?
    I deleted your prior activation on our end; it was still activated. That may help; if not, I can login and try to get it activated for you.

    #65267
    Anna
    Member

    Nicholas,
    Ok- I still cannot get into the admin with that login. And if I try directly to wp-admin it redirects me to the my-account page.
    So..
    If you go to your account here: https://www.wcvendors.com/my-account/downloads/
    Get your KEY
    then go to:
    wp-admin > settings > wc vendors pro license
    Try activating it again.

    Hopefully it will not give you the http://www.wcvendors.com message again.
    If it does, try manually updating to v1.4.3 and see if it works:
    To manually update Pro:
    1. back up your site (optional safe measure)
    2. download the latest Pro version from your account here: https://www.wcvendors.com/my-account/downloads/
    3. deactivate & then delete your current WC Vendors Pro (info/settings are stored in your database….)
    5. Immediately upload the new Pro version zip you downloaded from my-account.
    6. Activate! ?

    #65447
    Anna
    Member

    @nicholas
    Ok- no it is not letting me enter the license key since it thinks you are running on a local host.
    I wonder if this is due to the server perhaps? the cloudways?
    I will check with our lead developer and see if there is a way I can disable the local host check in Pro. I looked but was unable to locate exactly how he had this coded in.

    #65489
    Nicholas
    Participant

    Thank you, Anna. I appreciate it, and II shall await.

    Nicholas

    #65502
    Jamie
    Keymaster

    Hello,

    Looks like the code is functioning when it shouldn’t for everyone else. There is a line in

    includes/lib/class-wc-software-client.php line 198

    It currently reads

    if ( in_array( $_SERVER[ ‘REMOTE_ADDR’ ], $whitelist ) ){

    change it to

    if ( in_array( $_SERVER[ ‘SERVER_ADDR’ ], $whitelist ) ){

    and see how you go.

    If not cloudways is reporting your server host name in php some funky way. Please report back and let me know if that change fixed the issue.

    cheers,

    Jamie.

    #65507
    Nicholas
    Participant

    Hi Jamie,

    Thank you for looking into this. Yes, I too am just relieved the code is functioning despite the error/warning, whch I did too reckon it shouldn’t have worked for everyone else. I also hope the fact that the site was migrated from a WHM/CPanel account and onto this (Cloudways control using DigitalOcean droplet) doesn’t have anything to do with it.

    I have done what you instructed and changed the line (and commenting-out the previous line). Additionally, I purged Varnish from the server and restarted it. Unfortunately, the symptom persists.

    I have indeed tried to engage Cloudways into this and they have tried (in their limited capacity in the context of the plugins) to look into it, but to no avail.

    I hope that helps? (Please let me know if you prefer to have server admin access, and I’ll be happy to set such an account for you.)

    All the best,

    Nicholas

    #65601
    Nicholas
    Participant

    Update: I got a very confident note from Cloudways about replacing the same line, then moving on to other things as if they were sure this was the fix. And sure enough, the moment I changed it, that fixed it. The message is now gone, and I didn’t even have to restart the server. I reckon they knew about it directly based on your (Jamie’s) earlier assessment.

    This is their fix:

    Hi Nicholas,

    Sorry for the delay, regarding wcvendors, can you please replace code with this :

    if ( in_array( $_SERVER[ 'HTTP_X_REAL_IP' ], $whitelist ) ){

    Noting this here to update you but also in the off chance that it helps with WCV going forward.

    Speaking of which, may I just ask, will you be adapting that to WCV-Pro or is this specific enough for my/our install that I will need to update the plugin manually like this at every upgrade/update?

    Thanks!

    Nicholas

    #65604
    Anna
    Member

    @nicholas
    Glad it is working now! 🙂
    Jamie has added that to the Pro core, so it’ll be part of the next update.

    #65614
    Nicholas
    Participant

    Thanks, Anna! That’s awesome to know. (And a relief.)

    Please do extend my gratitude to Jamie as well.

    All the best,

    Nicholas

    #65623
    Anna
    Member

    @nicholas
    Awesome! 🙂

    #73215
    Tim Adams
    Participant

    I have the same problem with the site on a cloudways server – since most of this thread is marked private, could you let me know too how to solve it? Thanks!

    #73229
    Saud Razzak
    Participant

    Hi, I am Saud Razzak the WordPress community manager at Cloudways. Can you please let me know about your issue?

    #73235
    Tim Adams
    Participant

    I am using version 1.4.4. of the WCV Pro and the message “WC Vendors Pro has detected you are running on your http://www.wcvendors.com. The license activation system has been disabled.” appears.

    #73257
    Anna
    Member

    Hello,
    This issue will no longer be present once we release our next update.
    We had built-in a check for local installs, but it seems to be triggered far to often on certain hosts that are not local installs.

    #73261
    Tim Adams
    Participant

    Thanks for the update – it’s working so it is not critical, just annoying (and I think I cannot update without license activation, so I’ll have to upload it via ftp, I suppose)

Viewing 17 posts - 1 through 17 (of 17 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.