Minutes not working for product

Home Forums WooCommerce Bookings Integration Minutes not working for product

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #77323
    Clive Strydom
    Participant

    Hi

    When creating a bookable product via the frontend and I select 45min intervals this does not work. Hours works fine. It converts the minutes to months when I view the product in the backend using my Admin account.

    This is the same issue I believe as #65784.

    Any ideas? I upgraded the WC Bookings from Version 1.0.0 to the latest version which I think was 1.0.1 but that broke the frontend and only the general tab was available when creating a product (availability & cost was missing).

    Thanks,

    Clive

    #77324
    Clive Strydom
    Participant

    Just to add to this, when I enable access to the backend for vendor accounts and look at the product via the admin through the vendor account it constantly changes minutes to months. This then breaks the product on the frontend when the customer is viewing the product (basically is doesn’t allow the product to be selected by slots for the customer, just says please select options but no options are available).

    I’ll look into the code and see if I can find anything too.

    Thanks.

    #77326
    Clive Strydom
    Participant

    Okay, did some digging and I found that Woocommerce has the value set to ‘minute’ and your code has it set to ‘minutes’

    When I changed this in the following file all worked fine on both the setting up of the product and also the customer booking the product. The buffer period in minutes also works.

    /var/www/html/wp-content/plugins/wc-vendors-woocommerce-bookings/includes/class-wcv-wcb-product-controller.php

    starts at line 498 there are a few ‘minutes’ to change.

    This is probably all fixed already in the update 🙂

    #77508
    Anna
    Keymaster

    @clivestrydom
    Thank you- I will add this to our bookings integration issues so the it is attended to if it has not been fixed already.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘WooCommerce Bookings Integration’ is closed to new topics and replies.

Pro Bundle Special Offer 35% OFF

Get all the plugins essential for your marketplace website in one place and save. Over $600 value for just $397!

This website uses cookies to ensure you get the best experience on our website.