Home Forums WC Vendors Free Support PayPal IPN Failing

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #12054
    JohnDF
    Participant

    Hi Ben,

    I’m still on the free version…waiting for things to settle a bit before jumping into Pro.

    I don’t get a lot of PayPal payments, but all my IPNs from PayPal have been failing since September 18th. They were working fine for about a year before that, with the last successful one being on September 7th. It may be a coincidence, but September 18th was the release date of free version 1.7.8, and I updated that day (I also updated to 1.7.9 when it was released). This morning I received an email from PayPal alerting me to the IPN failures. This was the message:

    ——————————————–
    Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    http://{mydomain}/?wc-api=WC_PayPalAP&paypal_chain_ipn=1&order_id=5151

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.
    ——————————————–
    (NOTE: I replaced my domain above with {mydomain}…)

    I checked my IPN setup on PayPal today and it was in fact disabled. I re-enabled it and entered the following as the notification URL as you suggested in another recent thread:

    http://{mydomain}/?wc-api=WC_PayPalAP

    After doing this I checked my IPN history in PayPal later in the day and the IPN is still failing.

    Also an observation…the PayPal email above refers to order_id=5151, which is beyond the range of my current WooCommerce Order ID numbers.

    Any suggestions on how to fix this?

    Thanks Ben.
    …John

    #12055
    WC Vendors Support
    Participant

    It’s surely not a bug in the gateway, it’s going to be a webserver issue or a configuration issue. You don’t have to set the IPN return URL, WooCommerce handles all that automatically. Triple check your settings, and make sure you actually have a PayPal Adaptive Payments account, not a regular paypal account.

    #18316
    JohnDF
    Participant

    Hi Ben, or Jamie,
    I’ve spent many hours looking into this, and why it hasn’t been reported by other WCVendors users (as far as I can tell). One observation…around the time I started experiencing this problem (September 18th), it appears you may have been making changes in your code related to “Forced HTTP Protocol on Sent IPN URL”. In my Woocommerce>Settings>Checkout, I have both “Force secure checkout” and “Force HTTP when leaving the checkout” enabled. I suspect this might not be the usual setup for other users. Is there anything in your code that doesn’t work well with these settings?
    Thanks,
    John

    #18327
    WC Vendors Support
    Participant

    Hi John,

    If you want to test undoing this patch:

    Open: /classes/gateways/PayPal_AdvPayments/paypal_ap.php

    Change: $payRequest->ipnNotificationUrl = add_query_arg( $args, home_url( '/' ) );

    To: $payRequest->ipnNotificationUrl = str_replace( 'https:', 'http:', add_query_arg( $args, home_url( '/' ) ) );

    ….and that will roll back the IPN URL change.

    If that solves the problem for you, do let us know.

    Ben

    #36108
    JohnDF
    Participant

    Hi Ben, I undid the patch a couple of times, also after WCV version updates. I also tried turning off web application firewalls, but it’s still not working for me with or without the patch. I do have an update though…

    I changed the Notification URL configured in my PayPal account settings and made a test purchase. The following became obvious in reviewing the IPN History Log. PayPal is sending 2 separate IPN notifications for each purchase at the same time. One IPN (IPN type “Adaptive payment made”) is going to the notification url supplied through WCV, with no Transaction ID. The other IPN (IPN type “Transaction made”) includes a Transaction ID and is going to the Notification URL configured in my PayPal account settings, which is static and of course different from the url supplied through WCV. I’ve attached screenshots of the IPN details.

    Does this provide any clue about the source/resolution of the problem? You’ll also see “HTTP response code 503” for both IPN notifications, but maybe this is a result of the notification url discrepancies?

    Thanks.
    …John

    #36210
    WC Vendors Support
    Participant

    503 means Service Unavailable. That means your website isnt responding. Which means either your site was down, or PayPal couldnt communicate with your webserver. Both are issues we cant really do anything about. 🙁

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.