Home Forums WC Vendors Pro Support Sold products with quantity of 1 still showing, no orders displayed in dashboard

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.


Thank you to all of our customers!


Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #24862
    Jason Cyr

    I’ve got another thread where I’m trying to make it default that vendor products are a quantity of 1 and when purchased, disappear from the front end forever since these are unique items. I’m testing on my staging server and I went through as a buyer, purchased a product using your testing payment and completed the sale. In the admin I can see a sale has been made and is set as “processing.” However, when I log in as the seller it doesn’t show any orders.

    How can we troubleshoot this?


    WC Vendors Support

    Hi JC,

    That’s interesting. Curiosity, change the quantity in stock to 5, and test a quantity 1 purchase that way. Let me know the results.

    Jason Cyr

    Ok, so I set the product quantity to 5, made a purchase and the quantity is now 4. However, there still is not a sale showing in the user account. I went in as an admin and marked the sale from “pending” to “complete” and still nothing. I’ve disabled all plugins, all custom templates, functions.php in my child theme and still nothing. Ideally I need all products to be a quantity of 1 and when the person purchases a product it disappears on the front end and of course is reflected in the seller’s order tab. If you need to get in there and check things out just let me know.

    Thanks Ben!

    Jason Cyr

    I should also mention that as a buyer (when testing) I’m getting notifications that the sale has gone through so at least that seems to be working fine.

    Jason Cyr

    Hey guys…any thoughts on this? I’m a bit stressed about this since I’m trying to launch next week. Let me know if there’s any other troubleshooting steps I should take or you want admin access…

    WC Vendors Support

    Hi Jason,

    Sorry for my lagged replies, I’m out of town supporting my wife through a family emergency.

    – Do you have inventory management enabled in your WooCommerce settings? You will want to make sure it’s set to not allow backorders and that you’ve disabled the inventory hold time.

    – What gateway are you testing with? We provide the WC Vendors Test gateway specifically for testing, be sure you use it. If the gateway you are using now is setting orders to Pending, that’s not the WC Vendors Test gateway that is being used.

    – What is your commission rate set to? Did you override the commission rate by editing the vendors user account, or by editing the commission of the product? If so, make sure they are both “blank” there, so that it uses the global commission rate.

    Last but not least, if you still cant get it working, private reply with vendor user/pass and admin user/pass and your site URL so I can hop on and see what settings are checked incorrectly.

    Jason Cyr

    No worries…that’s obviously waaay more important so I appreciate your response. In Woo I have “enable stock management” selected and it was set to hold stock for 20 minutes, I’ve now left it blank to disable it. I’ve also enabled “hide out of stock items from catalog” as well.

    I was using your test gateway but I’m going to run some more tests and get back to you. If I have any issues I’ll give you admin access…thanks for the reply!

    WC Vendors Support

    Thanks Jason. Her father passed this morning, so now it’s funeral arrangements and things like that, and making sure her Mom is supported. Internet here is dialup, so its challenging to say the least. Still here, just not quite as fast as usual.

    Jason Cyr

    Well, I’m still having the same issue but jump on this next week. I’ll private message you all the deets…no need to worry about it now.


    I’m having the same issue. All of my items are individually product, but as they sell it still shows in the woocommerce marketplace. Any idea if this is just a box that needs to be checked?


    For one of a kind items..
    Ensure that you have stock enabled in your woocommerce settings:
    wp admin > woocommerce > settings > products > inventory
    Check :Enable stock management
    check : Hide out of stock items from the catalog

    Make sure that the vendors, when listing a product:
    Check: Manage Stock
    Enter Stock QTY: 1
    Check : Sold Individually


    Thank you for getting back to me.

    Is there a way to set by default. Eg..

    An item is added, by default it is set to:
    Check: Manage Stock
    Stock qty: 1
    Check: Sold Individually

    *Then they can change it if need. 98% of our products will be listed this way.


    I have an all or nothing solution–
    This would make it so all products are only sold once.
    At this time, I do not have an option that will allow the default to be one, and then also allow some items to have qty of more than one.
    This would go in your theme/child theme functions.php file. It will set the defaults for all products to:
    manage stock : checked
    qty: 1
    Sold only once : checked

    But it does seem to prevent these defaults from ever being changed. So, if you set this, you can go to the Pro product form settings and check the box to remove the inventory tab from the vendor’s product add/edit front end form– then there will be no confusion. (wp admin > woocommerce > wc vendors > product form: Manage Inventory (also disables all inventory fields) )


Viewing 13 posts - 1 through 13 (of 13 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.