Home Forums Stripe Commissions & Gateway Support Stripe says not connected, also live mode is not showing a gateway option

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #60613
    Leonard
    Participant

    Hi,
    I recently purchased the Stripe commission gateway. I have the Pro version of WC Vendors.
    My first issue is that when a vendor tries to connect, they get rerouted back to the site like it should after entering the stripe credentials for their account, however the dashboard still says “connect your account”. Its odd though, because in the stripe dashboard it is showing the connection was made. If i go to pay out commissions, it tells me no paypal accounts are connected.

    Second issue is when I try to go live there is no gateway on the site for a person to enter their CC information. The test mode works fine.

    Is there somewhere I need to enter a license code? Has anyone else encountered this?

    #61344
    Anna
    Member

    Hello,

    Its odd though, because in the stripe dashboard it is showing the connection was made. If i go to pay out commissions, it tells me no paypal accounts are connected.

    Our Stripe Commission & Gateway and Stripe connect only pay the commissions instantly at checkout; there is no option for manual, scheduled or NOW payment. That is all for PayPal Adaptive Payments.
    So if your vendor is connected, they will receive their commission payment to their Stripe account when the customer completes checkout. Site admin will receive their commission payment at that time as well.
    If your vendor is connected, I am not sure why the connect to stripe button is still showing.. are you using a cache on your site? If so, then please omit all of the dashboard pages form the caching plugin.. or if it is via your host/sever, please have them do so.

    For the second issue- that’s odd. So the customer cannot see the regular credit card fields that show at checkout? Are you using the Stripe modal form or the regular checkout page? (wp admin > woocommerce > settings > checkout > Stripe Connect : do you have ” Enable Stripe Checkout ” checked or un-checked?)

    #61690
    Leonard
    Participant

    Thanks. We just moved the site to our Production Site. It has an SSL. I recently read Stripe gateway docs and found that without an SSL the live mode would not be visible. Im hoping this reolves our issue.
    If we would like to be in control of when the vendor gets paid out, I suppose we just keep 100% of the charge and pay them manually? I wish there was a manual process through the stripe plugin.

    #62557
    James Lewis
    Participant

    @LEONARDBRUNO did SSL resolve your issue? I’m having the same problem on my site. The connect to stripe button does not show that a connection has been made even though I successfully went through the connect process. On the stripe dashboard it shows that a connection has been made successfully.


    @FERVOUS
    my host does cache my site. I have cleared the cache and the button still shows no connection was made.

    Any ideas?

    #62564
    Leonard
    Participant

    @smackmathew it did resolve. I was very happy. I moved the site to production and it resolved. Stripe accounts are connecting now and the live gateway is working.

    #62594
    Anna
    Member

    Hello,
    Yes- SSL is required to use Stripe in live mode.

    #63021
    James Lewis
    Participant

    @fervous I have SSL configured. I’ve checked and double checked all Stripe settings. Stripe is enabled, and running in live mode. Still when I click on the Connect With Stripe button, it successfully adds a connection on the Stripe website, but In the payment settings on the Pro dashboard, it still says “Your account is not yet connected with Stripe”.

    Any help would be appreciated.

    James

    #63375
    Anna
    Member

    @smackmathew
    James,
    If you go to your admin Stripe account, login.. then in the left menu click “CONNECT”. Once that screen is up, click the top link that says “Connected Accounts”.
    Is the vendor Stripe account actually connected to your admin Stripe Connect platform?

    #63393
    James Lewis
    Participant

    Sorry, I edited the post to make it private but it doubled the images.

    #63394
    Anna
    Member

    James.
    I deleted your post only because it contained private info– which although you made it a private reply- you are not the original author of this forum topic. So the original author can still see private replied (admin and original author can)
    I saved your post, and did view the screenshots.

    @fervous
    Yes, both the admin Stripe account, and the vendor Stripe account show the successful connection. I deleted the connections and tried it again, and it reconnected on both admin, and vendor accounts again. The only thing that doesn’t show the connection has been made is the WC Vendors Stripe plugin on my website(Pro Dashboard>Settings>Payment).

    I’ve attached some pictures to show this and what the Stripe settings are on my site.

    I appreciate your time and help.

    James

    I am doing some testing and I will reply again.

    #63395
    James Lewis
    Participant

    Oh, I think it’s also worthy to note that I followed a recommendation from another article here, to deactivate all plugins except the necessary plugins to test stripe (WooCommerce, WCVendors, Pro, WC Vendors Stripe Connect plugin). That produced the same results.

    #63396
    James Lewis
    Participant

    Thank you for your help. 🙂

    #64995
    nataliemaas
    Participant

    @smackmathew were you able to figure out your issue with the plugin? I have the same issue, but nobody from WC is getting back to me.

    #65022
    James Lewis
    Participant

    @nataliemaas No I have not been able to figure this out yet. Hoping WC will find a solution soon. For me it’s kind of a dead end without stripe payments working.

    #65127
    nataliemaas
    Participant

    @smackmathew oh wow. Yeah I can’t seem to get any help and I too, along with my team, is at a standstill with our whole project waiting on this stripe plugin! I’ll keep an eye on your thread to see if there is an answer soon!

    #65527
    Anna
    Member

    @smackmathew

    @nataliemaas

    This is a frustrating issue- I cannot replicate this on my dev sites.. everything is working fine with Stripe Commissions & Gateway.. as well as on my live marketplace as well.
    So- it is very difficult to debug and try and find the issue when I cannot replicate it.

    Obviously something is not right. I have asked Nataliemaas to provide login details on another thread- I am hoping to be able to isolate the issue while working on her site. It may be the same issue for both of you.


    @smackmathew
    When you go to your Stripe account > connect > connected accounts, do you see any connected users? Are the users actually being connected but the button is just still showing?

    Do both of you have your redirect url set to https if you are using https on your site?
    Look in Stripe > connect > settings > platform settings
    https://www.wcvendors.com/wp-content/uploads/2017/05/stripe1b.jpg

    #65764
    Sash
    Participant

    I need help, please. The Stripe payments are not being processed. Sigh..

    #66153
    James Lewis
    Participant

    @fervous I’m not sure what changed, but I tried connecting to stripe again before I replied to this string and it connected successfully, and now displays the connection on my site like it should. I have made no changes to any of the settings, and actually haven’t worked on this issue at all since I last messaged you here.

    I have however made sure all WordPress and plugin updates were done as they became available. I think there was even an update for the Stripe Commissions and Gateway plugin. Am I remembering that right? Could this have fixed this issue?


    @nataliemaas
    Is your site working?

    #66163
    nataliemaas
    Participant

    @SMACKMATHEW no it is not working yet. Anna did a test sign up and she is having the same issue as the vendors do. Very strange. Glad to hear yours is working though. I updated all my plugins, but will maybe go double check I did not miss any.

Viewing 19 posts - 1 through 19 (of 19 total)
  • The forum ‘Stripe Commissions & Gateway Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.