Successful creation of customer, but not charging

Home Forums Stripe Commissions & Gateway Support Successful creation of customer, but not charging

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

Thank you to all of our customers!


This topic contains 6 replies, has 2 voices, and was last updated by  ben 2 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #30194



    Would it be possible to look at my configuration of the Stripe Connect add-on? I am able to get it to connect with Stripe and successfully create a customer, but it won’t charge the client – resulting in a cancelled order.

    I received the cancelled order notification from one client three times in their attempt to place an order. They get an error stating: Error: Please make sure your card details have been entered correctly and that your browser supports JavaScript.

    When I put everything back in Test mode, I see that the customer is being logged into Stripe with their credit card info, but they are not being charged for the transaction. (As a side note, this had been a successful WooCommerce installation with the WooCommerce Stripe gateway, which has since been deleted.)

    What am I missing here? I’m happy to send both WordPress and Stripe login info if that helps.



    I could look if you provided wp-admin details and your site URL, sure. But in general, if something isnt set right, you’ll get errors. The error message you are getting is if the Stripe Token is empty. If it’s empty, it means you’ve got a config problem, most likely with how you and Stripe are talking to each other. First, I would run through the setup guide for Stripe again and ensure that your setup is correct.

    When I look at your site, all I can do is see if the checkboxes are correct. I dont have access to your account to check how Stripe talks to your site (and I wouldnt want access to that either, that’s all you 🙂 🙂 )



    Ok, Ben. Thank you, although it’s a new stripe account and I don’t have an issue with you checking out the Stripe account.

    Here is an admin login:

    Just a note, I try all of this on the test gateway and get no problems (except it’s not posting a charge, just a capture of all of the info, including CC number). I included a pic.

    Also, I included a pic of the Stripe “Connect” Platform Settings.



    Your Stripe settings in WooCommerce look good. However:


    Anything in RED means “YOU’RE DEAD!” 🙂 — Particularly, the My Account page is not set for WooCommerce. Set the page, even if you never use it, it must be set. This is Stripe’s callback page. “My Account” should have a slug of /my-account/ — contain the WooCommerce Shortcode for it [woocommerce_my_account], as well as be set correctly in wp-admin > Woo > Settings > Accounts.

    I would hope that this probably will fix the issue. Otherwise, you’ll want to follow this guide:

    And if that doesn’t do it, it’s something on your configs.




    Thanks for checking that out, Ben.

    I think there is definitely a problem here, though.

    I’ve gone in to the main Stripe area, and it shows that the vendor is connected in test mode, but not live mode. I’ve double checked the client_id keys, all is correct. I’ve reset the main account for Stripe keys, all is correct. Still, when I switch from Test to Live, it doesn’t show a connection to the vendor. When I go into the vendor’s Stripe dashboard, it shows a Dev mode connection only.

    So, I deleted the connection between the Stripe vendor and the main Stripe account, thinking that could resolve the issue and just reconnect. I went into the vendor’s area on wordpress and went to remove the connection to stripe. When I do, it just gives me a white screen with this in the address bar: But when I go back and login, it still shows connected.

    I don’t know if I’m at the point of needing paid assistance, but I’m more than happy to pay the $49.95 if you can solve this for me! You can call me at 503-999-5740. Thanks again for all of your help!!



    I’m also seeing in WordFence that the client that tried to purchase three times yesterday is also logged as having three failed login attempts. All purchases are through guest checkout. Would this be another issue? Is Stripe Connect trying to reach back and hook to the customer id number to finalize the purchase? Not trying to blow this up, but trying to find an answer and get this working! 🙂



    You can not use the same connect keys in live mode vs test mode. If a vendor has connected while you are in test mode, they need to disconnect and then reconnect once you are in live mode. If you get a white screen that’s because you probably have a website PHP error — check your webservers error_log for anything new relevant to Stripe and let me know!

    As for guest checkout, that should work fine, but I’ve never tested it at all.

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Stripe Commissions & Gateway Support’ is closed to new topics and replies.