Home Forums WC Vendors Pro Support [URGENT] Activating features in Pages tab caused redirect loop on my site!

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11180
    Stefan
    Participant

    Hey guys!

    I was editing my site all day today and just stumbled onto a major problem… for the second time. I’m freaking out!

    Here goes the story…

    I’m currently using the Pro version but I noticed that some options (if not most of them) in the free version have been disabled and are now blank.

    I didn’t really care for them that much, but later on I thought maybe it would be a good idea to show my Terms of Service page upon vendor registration. I really liked that feature in the free version!

    So, I opted to show the page that has my terms by selecting it from the relevant dropdown menu on the Pages tab in WC Vendors. I was so proud of my achievements… until I logged out, that is. 🙁

    When I tried to log back in, I couldn’t. The browser displayed the following message:

    This webpage has a redirect loop

    ERR_TOO_MANY_REDIRECTS

    Now I can only log in by typing my secret wp-admin word in the url and sign in with my admin credentials. I can browse the site, but the moment I try to log out, the browser displays that annoying message and nothing happens. The site won’t load for any other url, I’ve checked.

    Furthermore, when I type the homepage url, I see that it redirects to “/my-account” when the error message is shown, so clearly there is some conflict with the urls. And yes, I disabled the feature that caused this and even saved the permalinks to make sure my they don’t break, but still nothing!

    My previous solution:
    As I’ve mentioned, this happened to me twice already 🙁

    The first time, I did everything people advised on various forums but nothing worked. So I had to go to extremes and revert to a previous database backup. Unfortunately, I didn’t get to save my work today and I’ll lose my settings if I do, some plugins will revert back to default settings as well. Yesterday (when this happened for the first time), I spent all day configuring my settings the way they were. I’d rather not go through that again 🙁

    So I was hoping to share my awful experience here and avoid another database reset. At least, I narrowed it down this time and I am 100% sure what caused the problem!

    It’s the page settings in the Pages tab, like I said. Hope this helps find a solution that won’t require me to roll back to my old backup!

    Fingers crossed!

    #11181
    WC Vendors Support
    Participant

    Urgent problem? Fast reply! 🙂

    Sounds like you have deleted some of the pages. Make sure that ALL of the pages are set on the Pages tab, Pro tab, and Feedback tab. If they aren’t, WordPress likes to vomit, and break your site.

    The pages need to exist, with the correct shortcodes.

    Ben

    #11185
    Stefan
    Participant

    SOLVED!

    Thank you so much, Ben! You are a lifesaver 🙂

    I’ll just sum up the fix to make it easier for other users with the same problem.

    The fix
    I did exactly what Ben suggested. I filled out all blank fields in the Pages, Pro and Ratings tabs. I have no idea why they were blank.

    But more surprisingly, the Orders page was missing and I had to create a new one, paste the corresponding shortcode in it, and finally enable it in the Pages tab.

    Now my site works. It rose from the ashes like a phoenix and I feel like a kid on Christmas Eve, all thanks to the wonderful team behind WC Vendors. Best support ever!

    P.S. You can replace the “Urgent” label with “Fixed” if you wish, Ben.

    #11186
    WC Vendors Support
    Participant

    Thanks, glad that worked out for you. 🙂

    Tales of this successful fix will be told, and retold, for generations to come! 😉

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.