Home Forums WC Vendors Pro Support WCV Pro Suppress Author Archive Redirection

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #67576
    Meet June
    Participant

    Hi there,

    I need ‘subscriber’ author archives to be publicly accessible. I’ve tested multiple times and:

    1. I’ve found that when WCV Pro Is ENABLED, Author Archives REDIRECTS to the user dashboard, when the user is LOGGED OUT
    2. I’ve found that: When WCV Pro Is ENABLED, Author Archives are ACCESSIBLE when the user is LOGGED IN
    3. I’ve tested deactivating/reactivating every plugin and checked my hooks/filters
    4. I’ve flushed rewrites and cleared my cookies/cache multiple times
    5. I’ve checked my error logs and there are no errors
    6. I’ve gone through every class file in ~/wp-content/plugins/woo-payment-gateway-pro/includes/*
      but can’t seem to find any function/method that handles redirection

    I’m also trying to suppress WooCommerce’s author arhive redirection via:

    
    function enable_author_archives_for_customers() {
    	remove_action('template_redirect', 'wc_disable_author_archives_for_customers');
    }
    add_action( 'after_setup_theme', 'enable_author_archives_for_customers' );
    

    So, my question, is how can I suppress non-vendor author archive redirection? Is there a specific hook that I can remove?

    Thank you in advance!

    #67577
    Meet June
    Participant

    Hello again,

    I didn’t have my Pro host Dashboard set. I’ve since updated this and now it seems that the redirection isn’t happening. Does this make sense?

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.