Home Forums WC Vendors Pro Support 500 Error for Vendors

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #17044
    alwhit
    Participant

    I’m not getting very far with setting up Pro! I can’t see anyone else with this issue so posting up…

    I am getting a server 500 error on EVERY page on my site when I log in as a vendor. When logged in as admin, or logged out I have no problems. If I disable WCV Pro the problem goes away. Any ideas?

    Tried resetting permalinks and resetting vendor roles.

    #17045
    WC Vendors Support
    Participant

    Hi Alwhit,

    Oh no! Well, let’s try to figure it out. 500 Internal Server errors arent helpful. You need to provide us with some useful diagnostics such as:

    1.) What does your error_log say?

    2.) Did you try this with all plugins disabled except WooCommerce, WCV, WCV Pro?

    3.) Did you try switching to the default theme to test, too?

    4.) What URL are you using to login? The /my-account/ page or something else?

    Remember — When you ask a question — the more detailed your question is will save you a lot of time in waiting for a reply.

    #17046
    alwhit
    Participant

    OK, as an update – now worked out this isn’t happening for all Vendors. In fact it might only be 1 vendor giving me grief.

    #17047
    WC Vendors Support
    Participant

    That’s….interesting….. Have you ever used the “User Switching” plugin? It’s on WordPress.org for free. Install it, then go to wp-admin > users > vendors > and hover over that vendors account and click “Switch to”. It will log you in as them so you can see what they see. To “switch back” to your admin account, at the bottom of the page, click the Switch back to admin link. 🙂

    #17048
    alwhit
    Participant

    Here’s the error (had disabled error logging to get over the woocommerce issue I posted about yesterday!!)

    “Fatal error: Class ‘WC_Order’ not found in /var/sites/s/shetlandmarket.com/public_html/wp-content/plugins/wc-vendors-pro/public/class-wcvendors-pro-vendor-controller.php on line 154”

    #17049
    alwhit
    Participant

    Yes I use User Switching. The problem is that when I switch to the bad user the only way to get out of it is to clear my cookies and cache so that it logs me out, as I can’t get to any page including the admin dash!

    #17051
    alwhit
    Participant

    BINGO. “Front-End Theme Preview” plugin is to blame. That’s gone in the bin!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.