Trusted by Over 15,000 Marketplaces, and Growing! Forums Stripe Commissions & Gateway Support Stripe Payments only showing in USD – how can I fix this?

Tagged: ,

3 replies, 2 voices Last updated by Profile photo of Akatchi Akatchi 1 month, 2 weeks ago
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #48872 Score: 0
    Profile photo of Akatchi
    Akatchi
    Participant
    @akatchichi

    When I get to the checkout, my Stripe Gateway only shows the transaction in USD. I would like to use GBP but the total never shows as this when it comes to paying via Stripe. Even when the Stripe ‘pop up’ box is disabled and I use the inbuilt payment (e.g. enter the credit card details in the form) the transaction still processes in USD.

    I have tried to change the ‘data-currency’ to GBP to no avail, (even though the function us meant to use the Woocommerce currency which is GBP,

    Please advise, this is the only thing holding me back from fully using WCVendors.

    Thank you

    #48878 Score: 0
    Profile photo of ben
    ben
    WC Vendors Official Support
    265 pts
    @ben

    We just go based on your WooCommerce currency setting. What’s your currency set to in WooCommerce > Settings ?

    #48879 Score: 0
    Profile photo of Akatchi
    Akatchi
    Participant
    @akatchichi

    It’s currently set to Pounds Sterling (£)

    #49061 Score: 0
    Profile photo of Akatchi
    Akatchi
    Participant
    @akatchichi

    Managed to get the in-built form working, but the modal view still processes un USD only.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.