Home Forums WC Vendors Free Support Vendor Approval?

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #13330
    konakid
    Participant

    Everything is looking great Ben – I will be going to Pro as soon as it can support Woo Commerce Auctions.

    In the meantime, where do I find the approval notification when someone registers as a vendor? I don’t seem to be getting any notice that a new registrant has requested Vendor status, and it just automatically registers him as a Subscriber, as if he didn’t check the “Apply to Become a Vendor.”

    #13336
    konakid
    Participant

    Ben – additional info:

    You may remember that you registered on my site a few weeks ago to check out a problem and you became listed as a Vendor without any approval by me.

    But when I register a dummy account, I just get registered as a Subscriber – and I don’t see any way for me as a new user to select otherwise. And in addition, I don’t get any notice as Admin that this new user wants to be a Vendor – or else I could change role manually.

    I must be missing something simple – Sorry

    #13337
    WC Vendors Support
    Participant

    If it registers them as a Subscriber, they did not check the button. 🙂

    #13339
    konakid
    Participant

    Thanks Ben – but I double checked very carefully. Let me triple check and get back to you. 🙂

    #13347
    konakid
    Participant

    The only thing I hate worse than having to answer dumb user questions is asking them. 🙂 But sorry, it isn’t working for me.

    I triple and quadruple checked. Once checking the box before the Captcha and once after. I set my password from the email, logged in, and went to the Add Product link I created in the footer. I received this message – “You do not have sufficient permissions to access this page.” And when checking, the dummy user I created is a Subscriber each time.

    I even used a Firefox Private Browsing window in case it is a cache issue of some kind.

    If you want to confirm, I deleted your wcvendor account so you can use the same name and email – if I can talk you into registering again when you get a chance. http://www.tropiscape.com

    #13352
    WC Vendors Support
    Participant

    Are you auto approving vendors? If you auto approve them, admin doesn’t get bothered with new registrations. It’s only if there is a vendor *REQUIRING APPROVAL* by the admin that you get the email.

    #13354
    WC Vendors Support
    Participant

    I just registered, what does it show my user role as? Did you get an email? What is the email address you are sending email from on your webserver? (Set as private reply).

    #13390
    WC Vendors Support
    Participant

    If you don’t use /my-account/ to register, it won’t work. 🙂 Easy enough!

    #13398
    konakid
    Participant

    Thanks – great support – I know it isn’t easy. 🙂

    #24251
    Philip
    Participant

    Hi guys,
    sorry to drag up an old thread, but I’m having exactly the same issue as konakid was, but the solution (using /my-account/) doesn’t work for me, as the form I get is different.

    The shortcode on the My Account page is [woocommerce_my_account] and I have a screenshot below of the output on the front end. As you can see, it is just a log in form, not a registration one.

    Everything else works fine, I have been using the plugin for a few months now but have always add the Vendors manually before.

    Any ideas?
    Thank you.

    #24259
    WC Vendors Support
    Participant

    Hi Philip,

    wp-admin > WooCommerce > Settings > Accounts > [X] Enable Registration on My Account Page

    Cheers

    #24263
    Philip
    Participant

    Hi Ben,
    thanks so much, I would never have found that, I didn’t know it was a settings issue.
    It’s working perfectly now.
    Cheers 🙂
    Philip.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.
This website uses cookies to ensure you get the best experience on our website.