Commission not transferring to vendor

Home Forums Stripe Commissions & Gateway Support Commission not transferring to vendor

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

Thank you to all of our customers!

 

This topic contains 12 replies, has 4 voices, and was last updated by  ben 1 year, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #49188

    Megan Theodoro
    Participant

    I have configured all of my settings correctly, but when my vendor clicks on the connect to stripe button in their dashboard shop settings, it will redirect to stripe, allow them to sign in, and then redirect back to their my account page on the website. However, when they go back to the dashboard shop settings, the button still says connect to stripe, as if the connection didn’t work. In my stripe account it says the the vendor is connected, but when I test a live payment, I get 100% of the payment, and my vendor doest’t get their commission.

    #49273

    Anna
    Keymaster

    Megan, please reply with your WooCommerce System Status.
    I see that you have posted in multiple threads saying that you have the same issue as each of these threads.. however each issue is different. Are you having all of these issues? Have you attempted any of the suggested fixes that we and other users have gone through in the threads where you posted that you are having the same issue?
    https://www.wcvendors.com/help/topic/disconnecting-stripe-connect-account/
    https://www.wcvendors.com/help/topic/vendors-not-able-to-connect-to-stripe/
    https://www.wcvendors.com/help/topic/connect-to-stripe-button-not-working/

    Do you have SSL enabled on your site?

    Have you tried debugging by deactivating all plugins except WC Vendors (& Pro if you are using Pro), WooCommerce and the WC Vendors Stripe Commissions Gateway?

    #49279

    Megan Theodoro
    Participant

    I have only opened one thread, and the issue I am having is the same as the three others that have experienced the same issue. I read all three of the threads and did all of the troubleshooting suggested in each one and nothing had fixed the problem. Yes, I have SSL enabled, otherwise I wouldn’t be able to accept payment at all. I have deactivated all plugins and it still does not work.

    #49281

    Anna
    Keymaster

    Could you check your Stripe settings to ensure that your URL is entered uniformly in the site URL and redirect URL.. this was a fix that worked for another user having a similar issue:

    FIXED! In my Stripe settings I had URLs as https://mysite.com… It needed to be https://www.mysite.com for both the site and redirect URLs. I had assumed this was fine as the redirects were working, but it just wasn’t connecting.

    #49283

    Megan Theodoro
    Participant

    My site URL is my domain and my redirect is my domain with the /my-account attached to the end, per the setup instructions….should they both be the same?

    #49550

    Megan Theodoro
    Participant

    This issue has still not been resolved – can we troubleshoot to get it fixed please

    #51530

    I disabled all the plugins, switched over from official Storefront Proshop child theme to just Storefront, retried still with same result.

    I followed these instructions: “For the user you are connecting to Stripe, get their user ID #. Look in phpmyadmin in wp_usermeta for that user ID # and see if you see a meta key of “_stripe_connect_access_key”. If you do, is its value empty, or does it contain a string of letters/numbers? Al: Yours is empty which means Stripe isnt giving you the connect access key ID.” And searching for the vendor id I could not find the “_stripe_connect_access_key”. Surely that is a tip-off to something going wrong somewhere.

    I had the Stripe Settings URL and Redirect URL the same (as indicated in this thread), but I believe that is a mistake. The redirect should by https://aotv.shop/my-account/ and the regular should be https://aotv.shop I am running out of checking accounts to test this with.

    When a vendor connected with stripe using the button in the payment settings on WCV, a warning comes up with black and yellow stripes saying that the page is in development mode. However, the Stripe account did get set up on Stripe, just not on my site.

    I have 3 vendors so far that all got set up on Stripe, but none of them are connecting to my site. How can I get these 3 connected now, and how can I make the process work as it should for others in the future?

    I am using Storefront child theme Proshop, all standard woo commerce plugins. Will send System Status in another private reply.

    #51531

    Running this on WPENGINE

    
    ### WordPress Environment ###
    
    Home URL: https://aotv.shop
    Site URL: https://aotv.shop
    WC Version: 2.6.11
    Log Directory Writable: ✔
    WP Version: 4.7
    WP Multisite: –
    WP Memory Limit: 512 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: ❌ 5.5.9-1ubuntu4.20 - We recommend a minimum PHP version of 5.6. See: How to update your PHP version
    PHP Post Max Size: 100 MB
    PHP Time Limit: 3600
    PHP Max Input Vars: 1000
    cURL Version: 7.35.0
    OpenSSL/1.0.1f
    
    SUHOSIN Installed: –
    MySQL Version: 5.6.32
    Max Upload Size: 50 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 2.6.11
    : 
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔
    
    ### Active Plugins (23) ###
    
    Akismet: by Automattic – 3.2
    Easy WP SMTP: by wpecommerce – 1.2.3
    Email Users: by Mike Walsh & MarvinLabs – 4.8.4
    EWWW Image Optimizer Cloud: by Shane Bishop – 3.2.1
    Google Analytics: by ShareThis – 2.0.4
    Gravity Forms: by rocketgenius – 2.1.1
    Homepage Control: by WooThemes – 2.0.2
    Nav Menu Roles: by Kathy Darling – 1.8.6
    Restrict Content by Role: by Make Do  – 3.5.0
    Slider Revolution: by ThemePunch – 5.3.1.5
    Storefront Hamburger Menu: by WooThemes – 1.2.0
    Storefront Mega Menus: by WooThemes – 1.4.0
    Storefront Powerpack: by WooThemes – 1.3.0
    Storefront Product Sharing: by WooThemes – 1.0.3
    Theme Customisations: by WooThemes – 1.0.0
    WC Vendors - Stripe Commissions & Gateway: by WC Vendors – 1.0.4
    WC Vendors Pro: by WC Vendors – 1.3.7
    WC Vendors: by WC Vendors – 1.9.7
    Woocommerce CSV Import: by Allaerd Mensonides – 3.3.0
    WooCommerce Product Enquiry Form: by WooThemes – 1.2.1
    WooCommerce Subscribe to Newsletter: by WooThemes – 2.3.5
    WooCommerce: by WooThemes – 2.6.11
    WooCommerce Helper: by WooCommerce – 1.7.2
    
    ### Settings ###
    
    Force SSL: ✔
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    
    ### API ###
    
    API Enabled: ✔
    
    ### WC Pages ###
    
    Shop Base: #6 - /shop/
    Cart: #7 - /cart/
    Checkout: #8 - /checkout/
    My Account: #9 - /my-account/
    
    ### Taxonomies ###
    
    Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    ### Theme ###
    
    Name: ProShop
    Version: 2.0.4
    Author URL: https://woocommerce.com
    Child Theme: ✔
    Parent Theme Name: Storefront
    Parent Theme Version: 2.1.6
    Parent Theme Author URL: https://woocommerce.com/
    WooCommerce Support: ✔
    
    ### Templates ###
    
    Overrides: –
    
    ### WC Vendors Pro ###
    
    Theme Compatability: -
    Pro Dashboard Page: ✔ - #106
    Feedback form page: ✔ - #107
    Vendor Shop Permalink: ✔ - factory/
    
    ### Templates ###
    
    Overrides: –
    
    #51532

    ben
    Keymaster

    When a vendor connected with stripe using the button in the payment settings on WCV, a warning comes up with black and yellow stripes saying that the page is in development mode.

    DING DING DING! We have a winner. It’s probably stopping Stripe from being able to talk to your webserver since it’ll give them the “coming soon” page instead of an API answering reply.

    That’s my guess before I see the status report!

    #51567

    I did submit my status report in a private message. Yes, development appears to be it. So I am trying to figure out just why my WCVendors is running in development mode.

    Stripe support replied:

    From the screen shot you provided I can see that you are using the OAuth process for connecting your vendors. However, it looks like it is running in test mode. I’d suggest you or your developer take a look and adjust it to live mode. After making this switch to live mode, it should remove the “Development Mode” message at the top of the screen. Here are a couple of links with information on the OAuth process:

    https://stripe.com/docs/connect/standalone-accounts#integrating-oauth
    https://stripe.com/docs/connect/testing#using-oauth

    #51569

    ben
    Keymaster

    I did submit my status report in a private message. Yes, development appears to be it. So I am trying to figure out just why my WCVendors is running in development mode.

    Just to be clear we’re talking about the same thing, I should point out that WC Vendors does not have a development mode to be ran in. So, that’s not WC Vendors you are seeing. That’s something else on your site, another page, post, theme (Storefront child themes are not Storefront), or perhaps one of the twenty plugins that should be disabled during testing (leaving wcv, wcv pro, and woo enabled) ### Active Plugins (23) ### (from your status report).

    Let me know what you find!

    #51576

    ALL GOOD. User error. I had switched the Client IDs, and the testing Client ID and Production Client ID switched. I fixed, and then was able to connect the accounts. All is working normally, I placed an order and see now that the total price flows to the connected accounts, and that store portion shows as a fee on the Stripe payments. So at some point I am expecting to see those fees flow through to the store account.

    Very nice programming on WCVendors and Stripe. My congratulations to you. We are developers and know just how hard you work on this product.

    #51577

    ben
    Keymaster

    Glad you got it sorted. It’s always something silly, a checkbox somewhere, a weird value overlooked.

    Thanks for the compliments on the quality of WC Vendors and Pro/Stripe, much appreciated!

Viewing 13 posts - 1 through 13 (of 13 total)

The forum ‘Stripe Commissions & Gateway Support’ is closed to new topics and replies.