Home Forums WC Vendors Free Support Apply for vendor checkbox not showing up

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

  • This topic has 14 replies, 5 voices, and was last updated 7 years ago by Anna.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #60934
    Yong Lin Teh
    Participant

    Hi, i am running an e-commerce site. I have selected the options of “Allow users or guests to apply to become a vendor” , still the checkbox is not showing up at my-account page. Please help. It’s live now, I really need to get it fixed ASAP.

    #60938
    Josua
    Participant

    I am experiencing the same problem after recent WooCommerce and theme update

    #60945
    Anna
    Member

    Hello,
    Thank you for notifying us; I am doing some testing and if this is a bug then we will get this fixed asap!

    #60948
    Josua
    Participant

    Thank you so much @fervous. I hope it can be fixed soon

    By the way, I submitted Bahasa Indonesia translation for WC Vendors a couple weeks ago. When will it become available in update?

    #60962
    Yong Lin Teh
    Participant

    Hey did you update your woocommerce? cause I didn’t. Not sure if that’s the cause.

    #60977
    LocalTalents
    Participant

    I seem to be having the same issue, but not with all themes. In Storefront, I don’t see any checkbox. With Flatsome, I do. I’m still in testing/build luckily. I am trying to switch over to Storefront though, and got stuck when that box wouldn’t display.

    #61007
    Josua
    Participant

    Hey, @Yong. Yes, I did upgrade the WooCommerce and that’s when the problem comes. I think it’s necessary to keep the basic structures (WP, WC, and WC Vendors) updated all the time because they are crucial to my website.

    #61046
    Yong Lin Teh
    Participant

    Hi @fervous.Have you looked into my site ? Appreciate your prompt response.

    #61144
    Anna
    Member

    @yong @josuatarsisius @localtalents
    Thank you for notifying us- I assure you we are looking into this issue and I will update you with any news. If I find a temporary fix you can apply I will let you all know.
    Thank you for your patience.

    #63439
    sdbox
    Participant

    The same here, the checkbox doesn’t show up neither on my-account page nor in user sign up form. The recent update to 1.9.11 doesn’t fix anything.

    #63441
    Anna
    Member

    @sdbox
    What theme are you using?
    Have you tried switching to the Storefront theme to see if it is a theme conflict?
    Have your tried deactivating all plugins except woocommerce & WC Vendors to see if there is a plugin conflict?

    #63470
    sdbox
    Participant

    I do use the Storefront.
    I have tried about 5 different themes and there is not a single one where the checkbox shows up.
    I have also deactivated all plugins except woocommerce and wc-vendors so far no solution.

    #64232
    sdbox
    Participant

    I have checked the classs-vendor-signup.php and it looks like the
    add_action( 'woocommerce_register_form', array( $this, 'vendor_option' ) );
    is not doing its job and is not including the html-vendor-signup.php into the login form.
    The prove is that I can get the checkbox to the login form if I paste manually the include_once('views/html-vendor-signup.php'); into the WCV_Vendor_Signup constructor.
    I have fixed the problem by using this plugin https://en-ca.wordpress.org/plugins/woocommerce-simple-registration/ and adding a custom register link to my menu structure.

    #64237
    sdbox
    Participant

    I got I found the prob. The customer registration was not enabled in Woocommerce settings. This issue should be pushed to the dev team. The wc-vendor admin front end should not be able to allow the activation of vendor appplication if the woocommerce customer registration was not enabled. You should gray out this checkbox and put an explanation into the tooltip.

    #64340
    Anna
    Member

    Hello,
    Yes- you do need to have registration enabled in WooCommerce for the registration and apply to become a vendor checkbox to be available on the my-account page.
    Thank you for the suggestion.

Viewing 15 posts - 1 through 15 (of 15 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.