Home Forums WC Vendors Pro Support Invalid API License Key

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #57814
    Helixboardco
    Participant

    Hi,

    My API licence key failed, so I purchased another version as it looked like it expired in January, the new licence number has also failed stating ‘invalid API Licence Key’.

    Thanks

    Andrew

    #57837
    Anna
    Member

    @helixboardco
    Please ensure that you are running at least Pro version 1.3.8 if you wish to use the new license key.

    #57854
    Helixboardco
    Participant

    Hi,

    Where do I upgrade from 1.3.7. to 1.3.8. Trying to upload the new download fails as the folder already exists even when disabled, and I can’t see anywhere that says ‘upgrade’ like the rest of the plugins in woocommerce.

    Thanks

    Andrew

    #57875
    Anna
    Member

    Andrew,
    You can manually update.
    To manually update :
    1. back up your site (optional safe measure)
    2. download the latest Pro version from your account here: https://www.wcvendors.com/my-account/
    3. deactivate & delete your current WC Vendors Pro (info is stored in your database…)
    5. Immediately upload the new Pro version you downloaded from your my-account on here.
    6. Activate! ?

    #57889
    Helixboardco
    Participant

    Hi,

    Thank you, those instructions worked perfectly, and I was able to enter the new key successfully.
    However, when I attempt to checkout an item it still comes up with “internal server error”. I’ve contacted my hosting company and they have confirmed its an issue with WC Vendors Pro, as have Swift Ideas / Neighbourhood (the theme support group).

    Do you know what might be preventing adaptive checkout as we have confirmed with PayPal that all settings are correct with them.

    Thanks

    Andrew

    #57939
    Anna
    Member

    Hello,
    What do the last 20 or so lines of your error_log say?
    Do you have more than one paypal plugin active (you only need the adaptive payments that is included with wc vendors)?

    #57940
    Anna
    Member

    And when they confirmed that the issue was with WC Vendors Pro, what exactly did they say? Is that all they said?

    #58267
    Helixboardco
    Participant

    Hi,

    Currently the error log monitor isn’t working, see attached screenshot.

    Here is the message below from our hosting reseller:

    ———————
    Hello Andrew,

    Thank you for your email.

    I was able to replicate the issue and received ‘Internal Server’ error when I clicked on place order. I checked the error logs and found below details:

    ———————–
    [16-Feb-2017 19:33:16 UTC] PHP Fatal error: Cannot redeclare class OAuthDataStore in /home/helixandrew/public_html/wp-content/plugins/wc-vendors/classes/gateways/PayPal_AdvPayments/PayPal_AP/classes/adaptivepayments-sdk/lib/auth/PPAuth.php on line 826
    ———————–

    This seems to be an issue with the plugin ‘wc-vendors’ and the error occurs if there is a conflict with another plugin.
    ———————

    Thanks

    Andrew

    #58318
    Anna
    Member

    Hello,
    Please deactivate all plugins except WooCommerce, WC Vendors and WC Vendors Pro- then test. If the error is gone, then enable plugins one by one and test until you find the culprit. You did not share your WooCommerce System Status with us, so I do not know what or how many plugins you have installed and active on your site at the time.

    Please have your host help you enable your error log so you can see what is going on when you have errors appear on your site.

    #58545
    Helixboardco
    Participant

    Hi,

    I managed to successfully install error log monitor, disabled all plugins except for woocommerce, wc vendors pro, wc vendors and error log monitor and retried to purchase an item, it comes up with the following error, error log came up as empty.

    Thanks

    Andrew

    #58557
    Helixboardco
    Participant

    Hi,

    I finally got the error log monitor to work, I replicated the checkout error once again and the following error came up”

    ———————-
    Mar 08, 05:21:57
    PHP Fatal error: Cannot redeclare class OAuthDataStore in /home/helixandrew/public_html/wp-content/plugins/wc-vendors/classes/gateways/PayPal_AdvPayments/PayPal_AP/classes/adaptivepayments-sdk/lib/auth/PPAuth.php on line 826
    ———————-

    Thanks

    Andrew

    #58564
    Helixboardco
    Participant

    Hi,

    Our hosting reseller have also asked to send through the below message / error.
    Is it something they can fix?

    Thanks

    Andrew

    ——————
    I am getting the below mentioned error.

    =====================
    SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
    ====================

    I have checked and found that magic_quotes_gpc is disabled on server and json module is installed on server.

    Please do contact the plugin vendor and provide them above error message so that they will look into it.
    ——————

    #58608
    Anna
    Member

    Hello,
    Please pass along your WooCommerce System Status (wp admin > WooCommerce > System Status) as well as an admin login and password in a private reply. Thank you.

    #58613
    Helixboardco
    Participant

    Hi,

    I’ve attached the system status, and the login is:
    admin
    Afg128965

    Thanks

    Andrew

    #58629
    Anna
    Member

    Andrew,
    I did not receive the system status; I therefore do not know your URL.
    Have you checked with PayPal to ensure they are not seeing something on their end?

    #59273
    Helixboardco
    Participant

    Hi,

    Were you able to find out what the issue is with WC Vendors Pro plugin thats preventing a successful checkout via paypal adaptive payments?

    Thanks

    Andrew

    #59307
    Anna
    Member

    There is nothing in WC Vendors preventing a successful transaction….
    For some reason your Oauth is not working with PayPal.

Viewing 17 posts - 1 through 17 (of 17 total)
  • The forum ‘WC Vendors Pro Support’ is closed to new topics and replies.