This topic contains 19 replies, has 11 voices, and was last updated by Profile photo of Shane Shane 3 months, 3 weeks ago.

  • Author
    Posts
  • #50333 Score: 0
    Profile photo of Mo Mo 
    @simore103

    After installing WC Vendors PRO I noticed a bug in my website. I can’t install plugins from the wordpress repository anymore, I can upload but I can’t install from the repo. When I visit the “Add Plugin” page, I see a long list of errors displaying on the page, one being “Warning: uasort() expects parameter 1 to be array, null given in /home/content/p3pnexwpnas11_data03/38/3750238/html/wp-admin/includes/class-wp-plugin-install-list-table.php on line 217” and a long list of errors in “plugin-install.php” file, if I disable WC Vendors PRO plugin, all the errors disappear. Please tell me if I am missing something or if its your plugin issue then please let me know when will this bug be fixed. I have attached my website’s system report.

    #50335 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    Hello,
    This is a known issue that has been fixed, and the fix will be included in the next Pro update (soon!).
    https://www.wcvendors.com/help/topic/add-plugins-page-strange-issue/#post-49952

    #51611 Score: 0
    Profile photo of Jeffrey Jeffrey 
    4 pts
    @jwchameleoncorp

    Hi @anna

    Any idea when this will be fixed? I’m having the same issue.

    Cheers

    #51631 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    @jwchameleoncorp
    I have sent you an email with the file to fix this.
    The fix will be included int he next release; however, in the meantime you can replace the file following the instructions I gave in the email.

    #51632 Score: 0
    Profile photo of Jeffrey Jeffrey 
    4 pts
    @jwchameleoncorp

    Okay, thanks.

    #51696 Score: 0
    Profile photo of Nathan Nathan 
    @the_natural

    I am having the same issue, can you please send me the patch file?

    #51701 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    Nathan,
    I have sent the replacement file to you.

    Instructions:
    find this file:
    wp-content/plugins/wc-vendors-pro/includes/lib/class-wc-software-license-client.php
    Completely replace class-wc-software-license-client.php
    With the new class-wc-software-license-client.php attached.

    #52458 Score: 0
    Profile photo of Jesper Jesper 
    @budberra

    Please sen me one also

    #52475 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    @budberra
    OK- I have emailed you the file and instructions. ๐Ÿ™‚

    #52476 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    @budberra
    The email just bounced back… do you have a different email address I can send this to? I used the admin@ that you have registered here with WC Vendors.

    #52704 Score: 0
    Profile photo of MLE MLE 
    @bestmaker

    Hello, the same issue, can you send me the file?

    #52720 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    @bestmaker Ok- I have sent an email to you with the file & instructions.

    #52828 Score: 0
    Profile photo of john john 
    @johnhendley

    Hi, please send to me also, thanks J

    #52831 Score: 0
    Profile photo of Anna Anna 
    WC Vendors Official Support
    219 pts
    @fervous

    @johnhendley
    Sent ๐Ÿ™‚

    #52853 Score: 0
    Profile photo of john john 
    @johnhendley

    Thank you Anna, worked perfectly.

    #54555 Score: 0
    Profile photo of Angela Angela 
    @angie4media

    Hello, having this same issue with wc vendors pro. Can you please email the file. Thank You!

    #54561 Score: 0
    Profile photo of Jamie Jamie 
    WC Vendors Official Support
    89 pts
    @digitalchild

    Hello @angie4media

    We’ve released 1.3.9 so please jump onto your downloads page and download the latest update which includes this fix.

    cheers,

    Jamie.

    #54562 Score: 0
    Profile photo of Shane Shane 
    3 pts
    @shaneh

    Hi Jamie,

    I attempted to update to 1.3.9 but I get an error “Update Failed: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature” when trying to update through WordPress.

    I would do it manually but apparently for some reason now my site 500s after having this issue (2 + hours since I began troubleshooting it). I am using you guys for hosting and it worked fine before this. Now when I try to FTP or SFTP it refuses to connect. I haven’t change anything (and to attest to that I have my settings saved I just click login on SFTP client which was suggested to me by Ben).

    #54564 Score: 0
    Profile photo of ben ben 
    WC Vendors Official Support
    293 pts
    @ben

    That error is generally for a bad zip file. Our zip file isnt bad, but we’ve re-packaged it and re-uploaded it anyway. If you still have issues with the updater, please do bump this thread so we can investigate it further. Thanks!

    #54566 Score: 0
    Profile photo of Shane Shane 
    3 pts
    @shaneh

    Hey Ben,
    The new zip file you guys uploaded worked with the auto update button. I will check if that resolves the hosting issue.
    Thanks,
    Shane

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

ยฉ2009-2017 WC Vendors ยท Terms of Service, Support, and Refund Policies

Log in with your credentials

or    

Forgot your details?

Create Account