Loop Redirect Error

Home Forums WC Vendors Free Support Loop Redirect Error

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #4514
    Bibiana
    Participant

    When WC Vendors is disabled, the redirect loop disappears, when it is enabled, the error comes right back.

    When I try to access Login Form on Shop, it shows ERR_TOO_MANY_REDIRECTS.
    I can’t access any Costumer Page, like My Account or Cart.
    But I can login by Admin.

    I’ve tried both solutions here and no success.
    https://wordpress.org/support/topic/redirect-loop-51?replies=5

    I’ve check File Permissions too and they look fine (644).

    #4517
    ben
    Keymaster

    Try with WC Vendors, WooCommerce, and the TwentyFifteen Theme with NO other plugins activated. Let me know! I’ve never heard of this error before, I’m thinking it’s a conflict with another plugin or a poor theme.

    Ben

    #4544
    Bibiana
    Participant

    Hi Ben, there’s more people with the same problem here https://wordpress.org/support/topic/plugin-wc-vendors-redirect-loop-when-not-logged-into-wp-admin?replies=2#post-6833498

    I can’t disable all my plugin just to use WC. And my theme is a Premium theme. :/

    • This reply was modified 4 years, 6 months ago by  Bibiana.
    #4546
    ben
    Keymaster

    Hi Bibiana,

    I’m sorry to say, you still have to follow the testing methods. How do I know what the problem is if you won’t help test it to see what’s *causing* the problem? 🙂

    1.) Switch to the default TwentyFifteen theme. Try logging in. Does it work? If yes, then it’s a theme problem.

    2.) Switch back to your regular theme that you usually use. Disable all of your plugins except WooCommerce and WC Vendors. Does it work? If yes, then it’s a plugin conflict that is causing you the problem. Re-enable a plugin one at a time, and test each time. When it stops working again, the plugin you enabled is the culprit. 🙂

    The threads you reference on the web are very old, and and both of them were resolved by finding the incompatible theme or plugin.

    I’ve tested this extensively on our developer site, and on my own sites, and do not see anything related to this. As we power over 4000 stores, if people couldn’t login, there would be hell on this forum with many users experiencing the same problem. This is the only thread, so it must be a theme or a plugin conflict of some sort.

    I wish I was able to wave a magic wand and say “check this box”, but WordPress is not quite that simple. 😉 Follow the steps above and you should be able to figure out what the difficulty is, and when you do, please report back what the problem was. We’ll be here to help, but can only do so much with over 1 million themes and over 1 million plugins out there that people use on their sites. 🙂

    Remember — WC Vendors does not have any redirects in it. There’s 0 in the source code. It *must* be a plugin or theme incompatibility.

    Ben

    #4547
    Bibiana
    Participant

    I wish you had this magic power too lol
    Lets see…

    I’ve let:
    TwentyFifteen
    WooCommerce 2.3.7
    WC Vendors 1.6.2

    And the problem persist :/

    #4550
    ben
    Keymaster

    Fixed.

    You had deleted the Shop Settings Pages, and deleted the Orders pages. I re-created them, and set them in the settings.

    Oops!

    Don’t delete pages when plugins need them. 🙂 You should be all set now.

    Ben

    #4551
    Bibiana
    Participant

    Really??? Omg!
    LOL I’m feeling stupid.

    There’s more people working on this website. 😡

    Thank you so much 🙂

    #4552
    ben
    Keymaster

    You’re very welcome. We will add in a method in our next update that will either 1.) add a notice if you delete these important pages, or 2.) allows the site to work without them. I dont know if I’d call this a bug, but we can certainly make this less error prone if someone else makes the same thing in the future. 😉 First time I’ve ever seen anyone delete these pages! 🙂

    PS — The pages that I re-created for you are in English. You might want to edit the pages and put the titles in your native language instead. I’m not too well versed in other languages, hell, I’m barely competent in my own English language according to my wife. 😉

    Ben

    #4553
    Bibiana
    Participant

    That would be nice 🙂

    I really don’t even know why these pages weren’t there.

    Another quick question. My account is not a Vendor account.
    When I access this new pages I get:
    ORDERS -> [wcv_orders]
    SHOP SETTINGS -> Your account is not setup as a vendor.

    How can I put this notice “Your account is not setup as a vendor.” in ORDERS page too?

    Thank you.

    #4554
    ben
    Keymaster

    You can delete the shortcode from the pages, and enter any text you like. 🙂

    #5052
    Tempera
    Participant

    I must tell you that I also struggled with this error for days and didn’t know what to do about it or what was causing it.

    Until I started to deactivate plugins and I realized it’s because of WC Vendors and then I found this topic and realized it was because I deleted the “Orders” and “Shop Settings” pages… I couldn’t believe it was just this! But glad it was not some bigger issue.

    I deleted the pages because I don’t want to allow vendors to change settings and I didn’t find the “Orders” page was showing much new informations and it seemed redundant so I just thought I wouldn’t need them and deleted them.

    It’s good it’s solved now.

    #5054
    ben
    Keymaster

    Yup, easy fix. Lesson learned: Dont delete pages you have set in wp-admin! 🙂

    #34564
    Lisi
    Participant

    Hi- I am also having this same problem now. I don’t recall deleting any pages. If i reactivate the plugin will it recreate the page for me???

    #35205
    Creative Solutions
    Participant

    I agree with Facundo

    I had same issue. I did the following:

    adminlogin -> Plugins -> WC Vendors -> Settings -> Pages

    Set the pages properly “after reading” the instructions there. And save.

    #35439
    Obsi Dian
    Participant

    OMG – after googling and tearing my hair out for HOURS and trying a bunch of different things (some of which broke the site and I had to restore from backups)…. seems it was simply that my “orders” page wasn’t set either. I can’t believe I’d somehow missed that.

    *sigh*

    Given this is such a site-breaking issue, can those pages be already set by default? or some sort of message on the top of the screen letting people know it’s not set?

    #35452
    ben
    Keymaster

    Those pages *ARE* set by default. 🙂 It’s only the site admin that deletes them for some weird reason and forgets about it, and wonders how he broke his site later.

    There is also the WooCommerce System Status Report — If pages are missing, it’ll show up there, too, same as WooCommerce does for core. 🙂

    #37435
    Katlego
    Participant

    Hi

    I have the exact same problem but the pages are set on my site, and I have been struggling for hours.
    What is another solution for this?

    Thanks

    #37461
    ben
    Keymaster

    @katli — Chances are it is this problem, you’re just missing some of the tabs.

    wp-admin > WooCommerce > WC Vendors > Pages – Make sure the Free Dashboard, Orders, and Settings pages are set, and have the correct shortcode. The Terms & Conditions page is optional.
    wp-admin > WooCommerce > WC Vendors > Pro – Make sure the Pro Dashboard page is set, has the correct shortcode.
    wp-admin > WooCommerce > WC Vendors > Feedback – Make sure feedback page is set, and has the correct shortcode.
    wp-admin > WooCommerce > Settings > Accounts – Make sure my account page is set here, and that page has the correct shortcode.

    Also, remember that the Pro Dashboard and the Free Dashboard are two different pages, and you must have both set.

    #39136
    Victoria
    Participant

    Hello Ben, I have exactly the same problem than Bibiana, could you help me?
    Thanks
    Victoria

    #39138
    Victoria
    Participant

    🙁

    • This reply was modified 3 years, 3 months ago by  Victoria.
    #39145
    Anna
    Keymaster

    Victoria,
    This issue above was solved by checking to make sure that all of the pages for wc vendors were set properly.
    Please go to your wc vendors pages: wp-admin > woocomerce > wcvendors > pages and make sure those are correct with the correct shortcodes on each of those pages. Then go save your permalinks.

Viewing 21 posts - 1 through 21 (of 21 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.

This website uses cookies to ensure you get the best experience on our website.