Home Forums WC Vendors Free Support Vendor store page doesn't show

NOTICE: We've Moved to a Ticket System for Support

As of August 31, 2017 (12am EST) our support forums will be retired (read-only), and we will be moving to a support ticket system.  This will allow us to better organize and answer support requests, and provide a more personalized experience as we assist our customers.

For the time being, we will leave our forums open for reading and learning while we work on creating a more robust Knowledge Base for everyone to use.

If you are a WC Vendors Pro customer please open a support ticket here. 

If you are a WC Vendors user please open a support ticket on the Wordpress.org forums.

The information on this forum is outdated and in most instances no longer relevant. Please be sure to check our documentation for the most up to date information.

https://docs.wcvendors.com/

Thank you to all of our customers!

 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #58314
    ekevu
    Participant

    I installed wc vendors free. When I go to a product and click on a vendor’s name, it doesn’t lead me to the vendor’s page, but to the store overview page. Please test it here: https://mittagsfreunde.de/mittagskarte/dr-lehmann1/
    I followed this (https://www.youtube.com/watch?v=wHRh9oAM-Vo) tutorial and refreshed the permalinks, however, without success.
    Any ideas?

    #58333
    Anna
    Member

    ekevu,
    From what I can tell, that link is leading to that vendor’s store page. That is where that link- the “sold by” is intended to lead- the that vendor’s store page showing their own products.
    Am I incorrect in that the sold by is leading to the vendor store page?
    Did you think it was to lead to another page?

    #58353
    ekevu
    Participant

    It is not leading to the vendor store page, but to the general store page.

    #58409
    Anna
    Member

    Hello,
    Do you have the vendor permalink / url ending set to the same name as the woocommerce SHOP url?
    You have: /mittagskarte/ for your woocommerce main shop url
    If you have your vendor’s store set to the same thing (wp admin > woocommerce > wc vendors > general: Vendor Shop Page) than you need to change it to something different. They cannot both be the same url

    #58426
    ekevu
    Participant

    No, I don’t have them set to the same link as you can see when you go to the page https://mittagsfreunde.de/mittagskarte/dr-lehmann1/ and hover over “Dr. Lehmann” (as in “sold by”). It leads to “/restaurant”, however, when I click the link, I get forwarded to the shop page.

    #58519
    ekevu
    Participant

    I found a workaround: In the woocommerce settings, I did not assign any shop page under products → appearance → shop page. Now the vendor page is properly shown.

    #58537
    Anna
    Member

    Hello,
    Please ensure that you have the WooCommerce Shop Display set to: Products Only.
    wp admin > WooCommerce > Settings > Products > Display : Shop page display

    #58538
    Anna
    Member

    Ahh looks like you got there first. 😉 Great!

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘WC Vendors Free Support’ is closed to new topics and replies.